[Solved] Zenoss 4.2.5 slows with default gateway setup on Centos

2 posts / 0 new
Last post
Pheripheral
Pheripheral's picture
Offline
Last seen: 1 day 11 hours ago
Joined: 09/02/2015 - 04:52
Posts: 24
[Solved] Zenoss 4.2.5 slows with default gateway setup on Centos

Hi,

I've noticed an funny 'issue' with Zenoss 4.2.5 on Centos, having setup a default gateway in the network settings. I was wondering if aynone else had come across this or had an idea of what is causing the problem?

It seems that certain zenoss activities take a lot longer to complete once a default gateway has been added to the centos network setup (by adding GATEWAY=<ipaddresshere> to the /etc/sysconfig/network file and restarting network services / rebooting the server.

The simplest symptom i've found is that running zenoss status now seems to take several minutes to return with anything whereas without the gateway it takes about 5 to 10 seconds to report back the status of all the daemons etc...

Removing the gateway returns the performance of zenoss status to 5 to 10 seconds again.

Zenoss stops and starts also seem to take a lot longer and the modelling of devices takes a lot longer to get going than prior to the gateway setup.

Using some debug in the /opt/zenoss/etc/zenoss script has pointed to the fact that the zenoss script seems to wait a long time whilst the script calls 'zenpackdaemons --list' to get a list of the daemons but I'm out of ideas of why having a default gateway set should affect things in this way?

Can anyone shed any light on why having a network gateway should cause such an issue?

Thanks

Dafydd

 

 

 

 

Pheripheral
Pheripheral's picture
Offline
Last seen: 1 day 11 hours ago
Joined: 09/02/2015 - 04:52
Posts: 24
Solved (I think)

This seems to have been an issue with the DNS settings not setup correctly on the centos box.

Zenoss seems to have been attempting DNS lookups when doing a variety of tasks and with the dns not setup correctly the lookup retried many times with no response, holding things up for minutes.

Updating the Centos config to point to a valid dns server (in /etc/resolv.conf) seems to have recitfied ths issue and zenoss now plays nicely with the default gateway etc..

(alternatively a quick and dirty fix seemed to be added an entry for itself with the ip of its eth0 connection to the /etc/hosts file)

 

 

Hopefully this thread may be of use to someone else who may stumble across a similar issue...

 

Log in to post comments