Unable to process COMMAND

5 posts / 0 new
Last post
Jonas.stoltz
Jonas.stoltz's picture
Offline
Last seen: 5 days 15 hours ago
Joined: 03/13/2017 - 05:02
Posts: 4
Unable to process COMMAND

HI,

I'm having trouble with my 5.2.2 instance. It started with 5.0/5.1 and the latest upgrade did not solve anything. I also upgrade LinuxMonitor since I interpreted the fault to be there.

There is an alarm from every device in the class /Server/SSH/Linux;
"Unable to process COMMAND datasource(s) for device NAME-HERE -- skipping".

The traceback;
Traceback (most recent call last): File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 98, in _safeGetComponentConfig threshs = self._getComponentConfig(comp, device, perfServer, commands) File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 109, in _getComponentConfig for templ in comp.getRRDTemplates(): File "/opt/zenoss/Products/ZenModel/MetricMixin.py", line 141, in getRRDTemplates default = self.getRRDTemplateByName(self.getRRDTemplateName()) File "/opt/zenoss/Products/ZenUtils/FunctionCache.py", line 78, in wrapped_f value = f(*args, **kwargs) File "/opt/zenoss/ZenPacks/ZenPacks.zenoss.LinuxMonitor-2.1.2-py2.7.egg/ZenPacks/zenoss/LinuxMonitor/FileSystem.py", line 115, in getRRDTemplateName storage_server = list(self.getStorageServer()) File "/opt/zenoss/ZenPacks/ZenPacks.zenoss.LinuxMonitor-2.1.2-py2.7.egg/ZenPacks/zenoss/LinuxMonitor/FileSystem.py", line 148, in getStorageServer search_root = self.getDmdRoot('Devices').Storage AttributeError: Storage

Can anyone help me?

Jonas.stoltz
Jonas.stoltz's picture
Offline
Last seen: 5 days 15 hours ago
Joined: 03/13/2017 - 05:02
Posts: 4
I also got these "Critical";

I also got these "Critical";

Unhandled exception in zenhub service ZenPacks.zenoss.PythonCollector.services.PythonConfig.PythonConfig: Storage

Unhandled exception in zenhub service Products.ZenHub.services.SnmpPerformanceConfig.SnmpPerformanceConfig: Storage

Roberte
Roberte's picture
Offline
Last seen: 1 week 2 days ago
Joined: 03/14/2017 - 01:46
Posts: 14
rule of thumb: NEVER UPGRADE ZENOSS

Hi,

Upgrading the Linux Monitor zenpack from 2.1.0 (stock) to 2.1.2 in Zenoss 5.2.2 will break your install.
I downgraded back to 2.1.0 and the error is intermittent now.
I run the toolbox tools and it didn't fix the issue.
Remember this rule of thumb: NEVER UPGRADE ZENOSS/ZENPACKS UNLESS YOU REALLY NEED TO. You have to trust me on this.
I manually reinstalled 5.2.2. Let me know if you need further help with that. 

 

Kind regards,
Robert E.
zenoss@webhostingspace.net
Zenoss Core/Service Dynamics 5.2.2 High Availability - the missing guide is here

Jonas.stoltz
Jonas.stoltz's picture
Offline
Last seen: 5 days 15 hours ago
Joined: 03/13/2017 - 05:02
Posts: 4
Hi Robert,

Hi Robert,

 

Thanks for your help on that one. I (re)installed 2.1.0 and now I'm back with the error I had before. Storage (including graphs) now reports data at least.

The error headline is still the same "Unable..." with the trace;

 

Traceback (most recent call last): File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 98, in _safeGetComponentConfig threshs = self._getComponentConfig(comp, device, perfServer, commands) File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 139, in _getComponentConfig cmd.points = self._getDsDatapoints(comp, ds, ploader, perfServer) File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 64, in _getDsDatapoints dpc.data = parser.dataForParser(comp, dp) File "/opt/zenoss/Products/ZenRRD/ComponentCommandParser.py", line 67, in dataForParser return dict(componentScanValue = getattr(context, self.componentScanValue)) File "/opt/zenoss/Products/ZenModel/ManagedEntity.py", line 42, in __getattribute__ return super(ImplicitAcquisitionWrapper_ManagedEntity, self).__getattribute__(name) AttributeError: mount

When you say manual install; do you mean on a fresh machine? What abpout the data?

Or do you mean repeating steps in the upgrade guide?

KR,
Jonas

Jonas.stoltz
Jonas.stoltz's picture
Offline
Last seen: 5 days 15 hours ago
Joined: 03/13/2017 - 05:02
Posts: 4
Hi Robert,

Hi Robert,

 

Thanks for your help on that one. I (re)installed 2.1.0 and now I'm back with the error I had before. Storage (including graphs) now reports data at least.

The error headline is still the same "Unable..." with the trace;

 

Traceback (most recent call last): File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 98, in _safeGetComponentConfig threshs = self._getComponentConfig(comp, device, perfServer, commands) File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 139, in _getComponentConfig cmd.points = self._getDsDatapoints(comp, ds, ploader, perfServer) File "/opt/zenoss/Products/ZenHub/services/CommandPerformanceConfig.py", line 64, in _getDsDatapoints dpc.data = parser.dataForParser(comp, dp) File "/opt/zenoss/Products/ZenRRD/ComponentCommandParser.py", line 67, in dataForParser return dict(componentScanValue = getattr(context, self.componentScanValue)) File "/opt/zenoss/Products/ZenModel/ManagedEntity.py", line 42, in __getattribute__ return super(ImplicitAcquisitionWrapper_ManagedEntity, self).__getattribute__(name) AttributeError: mount

When you say manual install; do you mean on a fresh machine? What abpout the data?

Or do you mean repeating steps in the upgrade guide?

KR,
Jonas

Log in to post comments