Attempted Windows connection to non-Windows device

2 posts / 0 new
Last post
Cnealon
Cnealon's picture
Offline
Last seen: 1 month 4 days ago
Joined: 08/25/2015 - 04:06
Posts: 14
Attempted Windows connection to non-Windows device

Hi Guys,

Running into an issue scanning devices on other sites. This was working on 5.0.1 but now running 5.1.7

When modelling a device that is on the LAN here I get no errors.

However, when I run it against a device on another network (all pinging correctly etc)

I get ->

2017-02-07 09:17:49,251 INFO zen.PythonClient: running the following nmap command: /usr/bin/nmap -p 1-1024 -sT --open -oG - *.*.*.*

2017-02-07 09:17:49,255 ERROR zen.PythonClient: Error in zenoss.winrm.CPUs: attempted Windows connection to non-Windows device

2017-02-07 09:17:49,255 ERROR zen.PythonClient: Error in zenoss.winrm.FileSystems: attempted Windows connection to non-Windows device

2017-02-07 09:17:49,257 ERROR zen.PythonClient: Error in zenoss.winrm.WinMSSQL: DeviceProxy instance has no attribute 'windows_user'

2017-02-07 09:17:49,257 ERROR zen.PythonClient: Error in zenoss.winrm.WinCluster: attempted Windows connection to non-Windows device

2017-02-07 09:17:49,264 INFO zen.ZenModeler: No command plugins found for server.mydomain.com

 

Any ideas on what i could try?

 

Thanks

Jstanley
Jstanley's picture
Offline
Last seen: 6 hours 16 min ago
Joined: 07/10/2014 - 09:31
Posts: 213
The modelers/components for

The modelers/components for Windows need to have the Windows python class

 

zPythonClass = ZenPacks.zenoss.Microsoft.Windows.Device

But becareful doing this if you are changing from another type.

Log in to post comments