event notification email fails

6 posts / 0 new
Last post
Rick
Rick's picture
Offline
Last seen: 3 months 1 week ago
Joined: 12/19/2016 - 13:24
Posts: 4
event notification email fails

I just recently install Zenoss 5 core.  I have setup the smtp info and tested email. Email works on test. I have setup a trigger and notification. The trigger works, but the email notification is failing.. Here is the event info

Traceback (most recent call last): File "/opt/zenoss/Products/ZenModel/actions.py", line 321, in execute self.executeBatch(notification, signal, targets) File "/opt/zenoss/Products/ZenModel/actions.py", line 463, in executeBatch (notification.id, targets, errorMsg) ActionExecutionException: Notification 'Server_down' FAILED to send emails to set(['rick.baker@registerguard.com']): <class 'smtplib.SMTPServerDisconnected'> - please run connect() first

 

 

Jcurry
Jcurry's picture
Offline
Last seen: 1 day 11 hours ago
Joined: 01/02/2014 - 13:04
Posts: 391
Two thoughts.  One is to

Two thoughts.  One is to check the sender field for emails - if this is not a valid sender address then the mail server may reject it. So, for example, I use zenoss@skills-1st.co.uk.  Not sure whether this affects test emails - the test may take some "short-cuts".   Also double-check the SMTP port and TLS tick-box.

Your log shows that your email is being transferred into the notification (I assume correctly?).  By default, notifications take the general email parameters provided from ADVANCED -> Settings, but you can override this on a per-notification basis by scrolling down the notification dialog, Contents tab.  Do check that the Notification also has what you expect.

It is the zenactiond daemon that actually processes notifications for you so you might check that log too.

Cheers,

Jane

 

Rick
Rick's picture
Offline
Last seen: 3 months 1 week ago
Joined: 12/19/2016 - 13:24
Posts: 4
Still not luck

My mail server is seeing the test mail and sending it out... The server down event still does not work.  I can not find the log for zenactiond. Where might it be?

Rick
Rick's picture
Offline
Last seen: 3 months 1 week ago
Joined: 12/19/2016 - 13:24
Posts: 4
Fixed

I had called both the trigger and the notification with the same name. server_down.. I changed the notification to down_server and now it works.

Rick
Rick's picture
Offline
Last seen: 3 months 1 week ago
Joined: 12/19/2016 - 13:24
Posts: 4
still fixed

Turns out that i had to put in the smtp server, port and from address in the notification alert.  So why doesn't the default setup in the advanced setting work? same information in the advance settings and the notfication alert.

Jcurry
Jcurry's picture
Offline
Last seen: 1 day 11 hours ago
Joined: 01/02/2014 - 13:04
Posts: 391
That information SHOULD be

That information SHOULD be propagated by default to each Notification - provided you create the Notification through the GUI.  There IS an issue (still, I think with the latest release) if you create the Notification in a ZenPack through files in the zep directory.

What exact version are you on?

Cheers,

Jane

Log in to post comments