Kerberos errors while modelling

4 posts / 0 new
Last post
Makemorebeer
Makemorebeer's picture
Offline
Last seen: 11 months 14 hours ago
Joined: 04/23/2015 - 14:21
Posts: 44
Kerberos errors while modelling

i'm wondering if anyone has seen this issue with WINRM devices returning errors. it only happens on some servers, and i have not been able to figure out why. i'm thinking it's an issue with either the configuration on some servers (despite it being put out by GPO), or in some cases it appears zenoss is passing the ip address instead of the hostname? Any ideas?

2015-07-01 20:41:12,301 INFO zen.ZenModeler: Connecting to localhost:8789
2015-07-01 20:41:12,312 INFO zen.ZenModeler: Connected to ZenHub
2015-07-01 20:41:12,472 INFO zen.ZenModeler: Collecting for device appserver.conus.com
2015-07-01 20:41:12,575 INFO zen.ZenModeler: skipping WMI-based collection, PySamba zenpack not installed
2015-07-01 20:41:12,580 INFO zen.ZenModeler: Python collection device appserver.conus.com
2015-07-01 20:41:12,580 INFO zen.ZenModeler: plugins: zenoss.winrm.OperatingSystem, zenoss.winrm.CPUs, zenoss.winrm.FileSystems, zenoss.winrm.Interfaces, zenoss.winrm.Services, zenoss.winrm.Processes, zenoss.winrm.Software, zenoss.winrm.IIS
2015-07-01 20:41:12,586 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,590 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,594 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,598 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,601 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,605 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,609 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,612 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,616 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,620 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,624 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,628 ERROR zen.PythonClient: Error on appserver.conus.com: Server not found in Kerberos database: HTTP@172.17.10.45
2015-07-01 20:41:12,628 INFO zen.PythonClient: Python client finished collection for appserver.conus.com
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.OperatingSystem returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.CPUs returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.FileSystems returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.Interfaces returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.Services returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.Processes returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.Software returned no results.
2015-07-01 20:41:12,628 WARNING zen.ZenModeler: The plugin zenoss.winrm.IIS returned no results.
2015-07-01 20:41:12,628 INFO zen.ZenModeler: No change in configuration detected
2015-07-01 20:41:12,629 INFO zen.ZenModeler: No command plugins found for appserver.conus.com
2015-07-01 20:41:12,629 INFO zen.ZenModeler: SNMP monitoring off for appserver.conus.com
2015-07-01 20:41:12,629 INFO zen.ZenModeler: No portscan plugins found for appserver.conus.com
2015-07-01 20:41:12,629 INFO zen.ZenModeler: Scan time: 0.16 seconds
2015-07-01 20:41:12,630 INFO zen.ZenModeler: Daemon ZenModeler shutting down
2015-07-01 20:41:12,634 INFO zen.publisher: publishing failed: Connection was closed cleanly.

Makemorebeer
Makemorebeer's picture
Offline
Last seen: 11 months 14 hours ago
Joined: 04/23/2015 - 14:21
Posts: 44
i'm at a loss yet again. in

i'm at a loss yet again. in researching this problem i can setspn -l appserver and i get the list of acceptable SPNs. this implies to me that the entries are correctly in the database, at least at my DC. so what is generating this message? is it the zenoss VM? in this particular servers case the problem didn't start until i changed it's ip address. is there a way to completely clear any trace of the device from zenoss? for example, if i delete it and then add it back it retains it's local zproperties, leading me to believe it's not truly removed from Zenoss? perhaps since this ip address existed on a different server before this one that is my issue? is there anyone out there that can answer any of these questions?

Makemorebeer
Makemorebeer's picture
Offline
Last seen: 11 months 14 hours ago
Joined: 04/23/2015 - 14:21
Posts: 44
Problem solved, although

Problem solved, although probably not a great method. switching to using basic local authentication gets aroudn this issue.

http://www.zenoss.org/forum/134656

Ragmanii
Ragmanii's picture
Offline
Last seen: 1 month 1 week ago
Joined: 03/24/2015 - 12:50
Posts: 5
Sorry to resurrect this thread, but it is the top of the search
I ran into this same issue and it ended up being a PTR issue in DNS. There were 2 listings for this one server and it looks like when it pulls the PTR record it only pulls one. If you get this error check to see if you have multiple PTR records for the server you are having issues with. As soon as I changed to the other PTR that was also listed it modeled correctly.
Log in to post comments